Appointments to calendar

My appointments are not going to the correct time in my calendar once scheduled. Can anyone give me some advise on how to fix this. Thank you.

This could be down to a time zone mismatch. If you head to your Settings, then Times & availability > Language & time zones. You’ll see what your calendar is being detected as. If that is different from where you actually are, you’ll see events going into the calendar at the “wrong” times.

This page looks at how to fix this, depending on the type of calendar you’re using: