Availability - times are not appearing correctly


#1

I see available times in the program, but it won’t change my available times on the live page–I put 10-7 for M-F, but it shows 6am-2:45pm. Can you help? I have checked everything, I am sorry if this is a simple fix I am overlooking. - Susan


#2

Hey Susan, This was my issue too! You may want to check out your timezone, as depending on how your calendar is configured it may be reporting inaccurately. If you uncheck the auto detect you can manually select your timezone. You can check out this for more information: https://support.youcanbook.me/article/76-getting-the-timezone-setting-right-for-your-profile.


#3

That was it, it was reporting as UTC for some reason. I have changed this to be Eastern and everything is working correctly. Why was it recording as UTC?


#4

Hi Susan, Ben from the YCBM Team, hope I can help. By default we will pull in whatever your calendar is set up as. Some calendars like Microsoft won’t automatically adjust as they don’t send the timezone of the calendar through. We hope to have a fix in place to better detect timezones in this case in the future.


#5

Hope this gets fixed to prevent all the anxiety!