Setting up appointments which span over midnight

Hi all, I’m having issues in setting up calendar availability.

I run an escape room, which means my appointments have a durations of 60mins and an interval between appointments of 30mins (to reset and sanitize rooms).
I also have appointments which will start on the current day but end after midnight, so on the following day.
Basically, my actual game sessions schedule should be like this:

00:30AM -> 01:30AM
06:30PM -> 07:30PM
08:00PM -> 09:00PM
09:30PM -> 10:30PM
11:00PM -> 12:00AM

The only way I managed to make this work is by setting my working hours as 00:00 - 00:00, and:

  • using 90mins appointments (thus including the 30mins buffer. not ideal, but acceptable)
  • blocking out non-service hours on my Google calendar (i.e. from 1:31AM to 6:29PM)
  • using a 90mins grid

Anyway this is not good for me, as this way the appointments will start right at midnight -but if I set my working hours as 00:30 - 00:30 I cannot see any availability.
If I set my working hours to be 00:30 - 00:29 (or anything between 00:00 and 00:29) I lose the availability slot for the appointment which should take place a 11:00PM, as being a 90mins appointment will cross over the following day, but there won’t be enough time for a full appointment (89mins at best).

Maybe I’m missing something very obvious, but can anyone suggest how to create an availabilty setup which will accommodate my requirements?

Cheers,
Mauro

I also tried using Custom Availability using 00:00 - 00:00 as working hours, “Show availability” in increments of 1 hour, setting specific 1-hour “free” appointments in my Google calendar, according to this schedule:

  • 00:30AM -> 01:30AM
  • 06:30PM -> 07:30PM
  • 08:00PM -> 09:00PM
  • 09:30PM -> 10:30PM
  • 11:00PM -> 12:00AM

End result is that only appointments which fall on the hour (ie 08:00PM -> 09:00PM and 11:00PM -> 12:00AM) are showing in the preview, while the others which fall on XX:30 do not show up at all:

If I use 30min in “Show Availability”, keep the appointment to 60mins and add 30mins padding, this is the end result:

This is starting to look like what I need, but is there a way to prevent useless rows from showing up?
M.

Adding @Ben to the thread: I understant this might be solved with some CSS coding on your side.
Is this correct?

Mauro, having bookings span a day is tricky. Our grids are built with the 24 hour or day concept. With that said it should be possible to hide this time with something like: [dir] .gridNoFree {display:none;}

Keep in mind that newer booking pages may not have access to customize the CSS. If that is the case for you, send me a message and I will see what I can do.