Stopped syncing with my calendar

All of a sudden, my youcanbook me no longer syncs with my icloud calendar, so it shows I’m available all the time, when i have many meetings already on my calendar. I tried disconnecting and then re-integrating my calendar, and that didn’t fix it. In the integrations window, it says “Linking to 0 calendars from this account.” However, from my dashboard, calendars and teams tab, it shows all my icloud calendars and I have the one I want to sync with selected. I’ve used this for 4 months and have no idea why it stopped working. It’s useless now :< Any ideas how to fix?

Sometimes customers place events on their phone and they don’t make it through to the iCloud calendar we are connecting with. If you log into https://icloud.com and see your calendar, these are the blocking events we should be seeing. Also double check the calendar we are connecting with, so the blocking events may be on a different calendar you have setup.

Thanks for the advice. I checked both of those things, and neither are the problem. The events show up on iCloud (I’d made sure they were on the appropriate calendar) and I’ve triple checked what calendar I’m syncing with. Note, I mostly add events to my ical on my laptop (an imac) and I’ve been doing this seemlessly for 4 months. NONE of my meetings are syncing - before I’ve had trouble with one or two randomly not syncing, but this is none, and there are a lot. Anything else I can do? Because I’m sad to have to abandon youcanbookme, which I’ll have to do if i can’t work this out.

I checked on your bookings and it looks like they are cancelled within a few seconds of being booked. Our development team is looking into this issue. Apple is not updating their entire system with the new booking we are creating. When our system runs a review we can’t see the event and mark it as cancelled. One option in the interim would be to export your bookings from iCloud and import into a free Google calendar.

Thank you for checking on this! I’m going to just schedule my own appointments for a few days and hope this clears up.

Looks like this still hasn’t cleared up.

I know it can be a big inconvenience when things are not working as expected. Our team is still investigating this and working on a solution. I will update this thread once I have more information. Thank you for your patience.

Hi Support, I also have a similar issue.

Just noticed that some appointments are showing on my google calendar on my desktop but not on my android phone.

I’ve gone through the support link here to no avail.
https://support.google.com/calendar/answer/6261951?co=GENIE.Platform%3DAndroid&hl=en&oco=1
…so it doesnt look like an android issue.

Looking into this further, and enabling the advanced diagnostics in YCBM, I can see that YCBM sees the slot as busy which is correct, but cannot see the meeting in my live view even though it was scheduled through YCBM. (Ref: MJND-BJQM-VACY)

Please advise.
Thanks.

Hi Frank - we are still synching with your Google Calendar. The problem might be that your Android phone is not synching with your Google calendar. Some Android phone’s default to a calendar different than Google calendar. You’ll need to make sure your native calendar app is looking at the same Google calendar we are looking at for availability.

For example, booking MJND-BJQM-VACY is made for 11am on January 15. Since you are no longer available at 11am anytime that week, we have removed that time from your booking profile (more about that feature here: https://support.youcanbook.me/article/531-hiding-unavailable-rows)