My YCBM page is using my personal meeting room on zoom rather than creating a new meeting

My YCBM is integrated to my Zoom account. When a client books with me it is sending them to my personal meeting room rather than sending them a link to a unique meeting room. I do not want clients to be sent to my personal meeting room.
When I log into my Zoom account to join the meeting I am seeing it in my schedule but it is sending my to a unique meeting room while YCBM is sending my client to my Personal Meeting Room in ZOOM and is calling it an “impromptus zoom meeting”.
How do I make this stop? I dont want TCBM to have anything to do with my personal meeting room in zoom.

@arankin I am sorry for the frustration here. There is a setting in Zoom you may need to adjust. Can you check that you have: ‘Use Personal Meeting ID (PMI) when scheduling a meeting’: